Reports of issues - Item details page
Incident Report for SKULabs
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 05:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2024 - 21:34 UTC
Investigating
We have received reports of elevated errors when viewing item details and are investigating.

You can sign up for text/call/email updates at https://skulabs.statuspage.io/
Posted Mar 07, 2024 - 20:57 UTC
This incident affected: SKULabs (SKULabs App).