Canada Post elevated error rate
Incident Report for SKULabs
Resolved
This incident has been resolved.
Posted Jun 02, 2023 - 11:28 UTC
Identified
We have identified issues related to the Canada Post platform that may cause delays in retrieving rate quotes or purchasing shipping labels.

See Canada Post's status page: https://status.canadapost.ca/

See this article for advice: https://help.skulabs.com/en/articles/4424004

You can sign up for text/call/email updates at https://skulabs.statuspage.io/
Posted Jun 01, 2023 - 19:30 UTC
This incident affected: Shipping (Third-Party Shipping Integrations).