UPS - elevated error rate
Incident Report for SKULabs
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 20:01 UTC
Investigating
UPS is experiencing elevated error rate when fetching rates. We are monitoring this and will provide updates.
Posted Nov 09, 2020 - 15:59 UTC
This incident affected: Shipping (EasyPost API).