Reports of issues - FedEx reported technical difficulties
Incident Report for SKULabs
Resolved
There only remain intermittent reports of self-resolving issues with FedEx. If you're still encountering issues, please contact support.
Posted Mar 25, 2024 - 20:36 UTC
Investigating
We've received reports of errors within FedEx. They are currently experiencing technical difficulties. Some of the online services are temporarily unavailable. They are working quickly to resolve the issue.

You can sign up for text/call/email updates at https://skulabs.statuspage.io/
You can also check FedEx server status at https://www.fedex.com/apps/systemunavailable/
Posted Mar 25, 2024 - 14:15 UTC
This incident affected: Shipping (SKULabs Shipping, Shippo FedEx) and EasyPost FedEx.