Reports of issues from USPS

Incident Report for SKULabs

Resolved

The rate of errors has stabilized.
Posted Mar 24, 2025 - 21:53 UTC

Investigating

We have reports of issues related from a shipping provider that may prevent or cause delays in retrieving rate quotes, purchasing shipping labels, voiding or manifesting shipments.

See this article for advice: https://help.skulabs.com/en/articles/4424004

You can sign up for text/call/email updates at https://skulabs.statuspage.io/
Posted Mar 24, 2025 - 18:14 UTC
This incident affected: EasyPost USPS.