Endicia USPS - elevated error rate
Incident Report for SKULabs
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 20:01 UTC
Investigating
Endicia USPS is experiencing longer than normal response times and intermittent errors. Our engineers are monitoring this.
Posted Nov 09, 2020 - 16:04 UTC
This incident affected: Shipping (Endicia USPS).