Amazon Buy Shipping elevated error rate
Incident Report for SKULabs
Resolved
This incident has being resolved. Enjoy shipping
Posted Sep 20, 2022 - 12:38 UTC
Investigating
Multiple sellers are reporting delays/errors when fetching rates and creating labels through Amazon Buy Shipping.

We are constantly monitoring and will inform you once is resolved.
https://sellercentral.amazon.com/forums/t/error-using-amazon-shipping/1273628

Please sign up for text/call/email updates at https://skulabs.statuspage.io/
Posted Sep 19, 2022 - 15:07 UTC
This incident affected: Shipping (Third-Party Shipping Integrations).