Reports of Outage at FedEx
Incident Report for SKULabs
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 20:15 UTC
Investigating
We've received reports that Fedex is currently experiencing an outage causing issues when fetching rates and/or printing labels. Our team is actively monitoring this and will keep you updated. For more information, subscribe for updates at https://skulabs.statuspage.io/
Posted Jul 21, 2021 - 18:00 UTC
This incident affected: Shipping (Third-Party Shipping Integrations).