Reports of issues - Shipping Validation
Incident Report for SKULabs
Resolved
The validation queue has caught up as of 6:10pm ET.
Posted Sep 26, 2023 - 22:25 UTC
Investigating
We've received reports regarding shipping validation errors and are currently investigating.

You can sign up for text/call/email updates at https://skulabs.statuspage.io/
Posted Sep 26, 2023 - 22:23 UTC
This incident affected: Shipping (SKULabs Shipping).