EasyPost Elevated error rate
Incident Report for SKULabs
Resolved
This incident has been resolved.
Posted May 04, 2023 - 22:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2023 - 20:49 UTC
Update
The issue has been identified and a fix is being implemented.
Posted May 04, 2023 - 20:37 UTC
Identified
We have identified issues related to the EasyPost platform that may cause delays in retrieving rate quotes or purchasing shipping labels.

See this article for advice: https://help.skulabs.com/en/articles/4424004

You can sign up for text/call/email updates at https://skulabs.statuspage.io/

For EasyPost status updates: https://www.easypoststatus.com/incidents/cs6xl1tsm65m
Posted May 04, 2023 - 20:25 UTC
Investigating
We've received reports from EasyPost of elevated rates of errors and are investigating.

Status updates can be found @ https://www.easypoststatus.com/incidents/cs6xl1tsm65m
Posted May 04, 2023 - 20:12 UTC